New Membership Platform: Membee

The ACD Club is rolling out a new online membership system. All ACD Club Members should have receivied an email with enrollment instructions. You will use your email address as your login, and select a new password. This account will be used to renew your membership, update membership information, and make changes to your membership record.


This account is NOT THE SAME as your current account which you use to access the ACD Website Forums. Please continue to log into the Forums with the same username and password as you have always used. In the future we may consolidate the two accounts.

Startix Problems

More
05 Jul 2021 20:45 #43454 by pete kelly
Replied by pete kelly on topic Startix Problems
Have you checked the amp draw on the line to the starter?
Have you tried it with just 1 battery?

Please Log in or Create an account to join the conversation.

  • mikespeed35
  • mikespeed35's Avatar
  • Offline
  • ACD Club Life Member
  • ACD Club Life Member
More
07 Jul 2021 04:01 #43463 by mikespeed35
Replied by mikespeed35 on topic Startix Problems
I use i wet cell battery with about 550 CCA with no trouble. Why do you need two Optima? That's a lot of Amps.
CORDiallyMike

Mike Huffman

Please Log in or Create an account to join the conversation.

More
07 Jul 2021 13:40 #43464 by Curt Schulze
Replied by Curt Schulze on topic Startix Problems
He needs two batteries to overcome the resistance between the starter motor and ground. Most likely it is the ground brushes to the end plate.

The bitterness of poor quality remains long after the sweetness of low price is forgotten.
Be of Good Cheer
Curt
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Jul 2021 17:37 #43466 by A.S. KOLLER
Replied by A.S. KOLLER on topic Startix Problems
Thanks all for your comments.
The project car was set up with two batteries when I purchased it.
It was mid restoration with the engine not finished so I have no idea why he added the extra battery.
My understanding however is that while the batteries do have a lot of amps, electrical devices only draw what they need so I don't think that this would be the problem.
If the starter is faulty it could be drawing too many amps causing the problem.
I have ordered an amp clamp to test the draw and will keep you posted
Thanks
Steve Koller

Please Log in or Create an account to join the conversation.

Time to create page: 0.360 seconds
Powered by Kunena Forum